読者です 読者をやめる 読者になる 読者になる

pblog

pplog.net を作っている @ppworks こと越川直人(Koshikawa Naoto)のブログ

opensocial-actionscript-clientライブラリを使ってみ・・・るのを止めた

mixiアプリ OpenSocial FLASH Actionscript3

以前opensocial-actionscript-clientライブラリはflex向けとか書きましたが

Opensocial-actionscript-client is an Opensocial library for Actionscript/Flex/Flash

とあるように、Flashでもいけそうですね。では試してみます。

opensocial-actionscript-clientライブラリを用意する

google codeにソースコードがあります。

http://code.google.com/p/opensocial-actionscript-client/
Downloadする

Downlows tabのところにあります。このプロジェクトではsubversionにtagが存在していないようなので、こちらのDownloadsリストに各バージョン(tagにあたるもの)がリストされているようです。

com\nextgenapp\opensocial\Message.as
**Error** os-as-lib-081-02\src\com\nextgenapp\opensocial\Message.asMessage.as、行 14: 1202: パッケージ message 内の未定義のプロパティ com.nextgenapp.opensocial へのアクセスです。
     public static var Type:Class = com.nextgenapp.opensocial.message.Type;

おっと、Message.asでimport漏れがあるようです。

com\nextgenapp\opensocial\Message.as

importしてあげます。flexだとエラー出ないのだろうか?

import com.nextgenapp.opensocial.message.Type;
flex_sdk_3.3\frameworks\projects\framework\src\mx\core\Version.as
**Error** flex_sdk_3.3\frameworks\projects\framework\src\mx\core\Version.asVersion.as、行 18: 1004: 名前空間が見つからないか、コンパイル時定数ではありません。
     mx_internal static const VERSION:String = "3.3.0.4852";

flex SDK内のVersion.asのエラー。よく分かりません。CS4ではエラー出ませんでした。

com\nextgenapp\opensocial\standard\StandardDataRequest.as

これはflashだとクラスとして認識出来ないのでしょうか。

**Error** os-as-lib-081-02\src\com\nextgenapp\opensocial\standard\StandardDataRequest.asStandardDataRequest.as、行 25: 1046: 型が見つからないか、コンパイル時定数ではありません : StandardXMLOS。
     private var _xmlFunctions:StandardXMLOS = null;

**Error** os-as-lib-081-02\src\com\nextgenapp\opensocial\standard\StandardDataRequest.asStandardDataRequest.as、行 30: 1120: 未定義のプロパティ StandardXMLOS へのアクセスです。
     _xmlFunctions = _container.xmlFactory as StandardXMLOS;

これ以外にもWarningが沢山出ました。やる気が失せたので、opensocial-actionscript-clientはしばらく放置しますよ!
とりあえず今後は、opensocial-as3-clientの方をもうちょっと見ていきます。